Tech

Networking Tips – Blocking Whatsapp On Cisco IOS/Mikrotik ROS

Sometimes you may need to configure filtering of whatsapp at a customer network.

Here is a quick & painless method.

Mikrotik RouterOS

Step #1 – Configure the Address List

/ip firewall address-list
add address=31.13.64.51 list=whatsapp
add address=31.13.65.49 list=whatsapp
add address=31.13.66.49 list=whatsapp
add address=31.13.67.51 list=whatsapp
add address=31.13.68.52 list=whatsapp
add address=31.13.69.240 list=whatsapp
add address=31.13.70.49 list=whatsapp
add address=31.13.71.49 list=whatsapp
add address=31.13.72.52 list=whatsapp
add address=31.13.73.49 list=whatsapp
add address=31.13.74.49 list=whatsapp
add address=31.13.75.52 list=whatsapp
add address=31.13.76.81 list=whatsapp
add address=31.13.77.49 list=whatsapp
add address=31.13.78.53 list=whatsapp
add address=31.13.80.53 list=whatsapp
add address=31.13.81.53 list=whatsapp
add address=31.13.82.51 list=whatsapp
add address=31.13.83.51 list=whatsapp
add address=31.13.84.51 list=whatsapp
add address=31.13.85.51 list=whatsapp
add address=31.13.86.51 list=whatsapp
add address=31.13.87.51 list=whatsapp
add address=31.13.88.49 list=whatsapp
add address=31.13.90.51 list=whatsapp
add address=31.13.91.51 list=whatsapp
add address=31.13.92.52 list=whatsapp
add address=31.13.93.51 list=whatsapp
add address=31.13.94.52 list=whatsapp
add address=31.13.95.63 list=whatsapp
add address=50.22.198.204/30 list=whatsapp
add address=50.22.210.32/30 list=whatsapp
add address=50.22.210.128/27 list=whatsapp
add address=50.22.225.64/27 list=whatsapp
add address=50.22.235.248/30 list=whatsapp
add address=50.22.240.160/27 list=whatsapp
add address=50.23.90.128/27 list=whatsapp
add address=50.97.57.128/27 list=whatsapp
add address=75.126.39.32/27 list=whatsapp
add address=108.168.171.224/27 list=whatsapp
add address=108.168.174.0/27 list=whatsapp
add address=108.168.176.192/26 list=whatsapp
add address=108.168.177.0/27 list=whatsapp
add address=108.168.180.96/27 list=whatsapp
add address=108.168.254.65 list=whatsapp
add address=108.168.255.224 list=whatsapp
add address=108.168.255.227 list=whatsapp
add address=157.240.0.53 list=whatsapp
add address=157.240.2.53 list=whatsapp
add address=157.240.3.53 list=whatsapp
add address=157.240.7.54 list=whatsapp
add address=157.240.8.53 list=whatsapp
add address=158.85.0.96/27 list=whatsapp
add address=158.85.5.192/27 list=whatsapp
add address=158.85.46.128/27 list=whatsapp
add address=158.85.48.224/27 list=whatsapp
add address=158.85.58.0/25 list=whatsapp
add address=158.85.61.192/27 list=whatsapp
add address=158.85.224.160/27 list=whatsapp
add address=158.85.233.32/27 list=whatsapp
add address=158.85.249.128/27 list=whatsapp
add address=158.85.254.64/27 list=whatsapp
add address=169.44.23.192/27 list=whatsapp
add address=169.44.36.0/25 list=whatsapp
add address=169.44.57.64/27 list=whatsapp
add address=169.44.58.64/27 list=whatsapp
add address=169.44.80.0/26 list=whatsapp
add address=169.44.82.96/27 list=whatsapp
add address=169.44.82.128/27 list=whatsapp
add address=169.44.82.192/26 list=whatsapp
add address=169.44.83.0/26 list=whatsapp
add address=169.44.83.96/27 list=whatsapp
add address=169.44.83.128/27 list=whatsapp
add address=169.44.83.192/26 list=whatsapp
add address=169.44.84.0/24 list=whatsapp
add address=169.44.85.64/27 list=whatsapp
add address=169.44.87.160/27 list=whatsapp
add address=169.45.71.32/27 list=whatsapp
add address=169.45.71.96/27 list=whatsapp
add address=169.45.87.128/26 list=whatsapp
add address=169.45.169.192/27 list=whatsapp
add address=169.45.182.96/27 list=whatsapp
add address=169.45.210.64/27 list=whatsapp
add address=169.45.214.224/27 list=whatsapp
add address=169.45.219.224/27 list=whatsapp
add address=169.45.237.192/27 list=whatsapp
add address=169.45.238.32/27 list=whatsapp
add address=169.45.248.96/27 list=whatsapp
add address=169.45.248.160/27 list=whatsapp
add address=169.46.52.224/27 list=whatsapp
add address=169.47.5.192/26 list=whatsapp
add address=169.47.6.64/27 list=whatsapp
add address=169.47.33.128/27 list=whatsapp
add address=169.53.29.128/27 list=whatsapp
add address=169.53.48.32/27 list=whatsapp
add address=169.53.71.224/27 list=whatsapp
add address=169.53.81.64/27 list=whatsapp
add address=169.53.250.128/26 list=whatsapp
add address=169.53.252.64/27 list=whatsapp
add address=169.53.255.64/27 list=whatsapp
add address=169.54.2.160/27 list=whatsapp
add address=169.54.44.224/27 list=whatsapp
add address=169.54.51.32/27 list=whatsapp
add address=169.54.55.192/27 list=whatsapp
add address=169.54.193.160/27 list=whatsapp
add address=169.54.210.0/27 list=whatsapp
add address=169.54.222.128/27 list=whatsapp
add address=169.55.67.224/27 list=whatsapp
add address=169.55.69.128/26 list=whatsapp
add address=169.55.74.32/27 list=whatsapp
add address=169.55.75.96/27 list=whatsapp
add address=169.55.126.64/26 list=whatsapp
add address=169.55.210.96/27 list=whatsapp
add address=169.55.235.160/27 list=whatsapp
add address=173.192.162.32/27 list=whatsapp
add address=173.192.219.128/27 list=whatsapp
add address=173.192.222.160/27 list=whatsapp
add address=173.192.231.32/27 list=whatsapp
add address=173.192.234.96/27 list=whatsapp
add address=173.193.198.96/27 list=whatsapp
add address=173.193.205.0/27 list=whatsapp
add address=173.193.230.96/27 list=whatsapp
add address=173.193.230.128/27 list=whatsapp
add address=173.193.230.192/27 list=whatsapp
add address=173.193.239.0/27 list=whatsapp
add address=174.36.208.128/27 list=whatsapp
add address=174.36.210.32/27 list=whatsapp
add address=174.36.251.192/27 list=whatsapp
add address=174.37.199.192/27 list=whatsapp
add address=174.37.217.64/27 list=whatsapp
add address=174.37.243.64/27 list=whatsapp
add address=174.37.251.0/27 list=whatsapp
add address=179.60.192.51 list=whatsapp
add address=179.60.193.51 list=whatsapp
add address=179.60.195.51 list=whatsapp
add address=184.173.136.64/27 list=whatsapp
add address=184.173.147.32/27 list=whatsapp
add address=184.173.161.64 list=whatsapp
add address=184.173.161.160/27 list=whatsapp
add address=184.173.173.116 list=whatsapp
add address=184.173.179.32/27 list=whatsapp
add address=185.60.216.53 list=whatsapp
add address=185.60.218.53 list=whatsapp
add address=192.155.212.192/27 list=whatsapp
add address=198.11.193.182/31 list=whatsapp
add address=198.11.251.32/27 list=whatsapp
add address=198.23.80.0/27 list=whatsapp
add address=208.43.115.192/27 list=whatsapp
add address=208.43.117.79 list=whatsapp
add address=208.43.122.128/27 list=whatsapp

Step #2 – Drop rule

/ip firewall filter
add chain=forward src-address-list=whatsapp action=drop
add chain=forward dst-address-list=whatsapp action=drop

Cisco IOS

Step #1 – Access List

ip access-list extended lan-to-internet
deny ip any host 31.13.64.51
deny ip any host 31.13.65.49
deny ip any host 31.13.66.49
deny ip any host 31.13.67.51
deny ip any host 31.13.68.52
deny ip any host 31.13.69.240
deny ip any host 31.13.70.49
deny ip any host 31.13.71.49
deny ip any host 31.13.72.52
deny ip any host 31.13.73.49
deny ip any host 31.13.74.49
deny ip any host 31.13.75.52
deny ip any host 31.13.76.81
deny ip any host 31.13.77.49
deny ip any host 31.13.78.53
deny ip any host 31.13.80.53
deny ip any host 31.13.81.53
deny ip any host 31.13.82.51
deny ip any host 31.13.83.51
deny ip any host 31.13.84.51
deny ip any host 31.13.85.51
deny ip any host 31.13.86.51
deny ip any host 31.13.87.51
deny ip any host 31.13.88.49
deny ip any host 31.13.90.51
deny ip any host 31.13.91.51
deny ip any host 31.13.92.52
deny ip any host 31.13.93.51
deny ip any host 31.13.94.52
deny ip any host 31.13.95.63
deny ip any 50.22.198.204 0.0.0.3
deny ip any 50.22.210.32 0.0.0.3
deny ip any 50.22.210.128 0.0.0.31
deny ip any 50.22.225.64 0.0.0.31
deny ip any 50.22.235.248 0.0.0.3
deny ip any 50.22.240.160 0.0.0.31
deny ip any 50.23.90.128 0.0.0.31
deny ip any 50.97.57.128 0.0.0.31
deny ip any 75.126.39.32 0.0.0.31
deny ip any 108.168.171.224 0.0.0.31
deny ip any 108.168.174.0 0.0.0.31
deny ip any 108.168.176.192 0.0.0.63
deny ip any 108.168.177.0 0.0.0.31
deny ip any 108.168.180.96 0.0.0.31
deny ip any host 108.168.254.65
deny ip any host 108.168.255.224
deny ip any host 108.168.255.227
deny ip any host 157.240.0.53
deny ip any host 157.240.2.53
deny ip any host 157.240.3.53
deny ip any host 157.240.7.54
deny ip any host 157.240.8.53
deny ip any 158.85.0.96 0.0.0.31
deny ip any 158.85.5.192 0.0.0.31
deny ip any 158.85.46.128 0.0.0.31
deny ip any 158.85.48.224 0.0.0.31
deny ip any 158.85.58.0 0.0.0.127
deny ip any 158.85.61.192 0.0.0.31
deny ip any 158.85.224.160 0.0.0.31
deny ip any 158.85.233.32 0.0.0.31
deny ip any 158.85.249.128 0.0.0.31
deny ip any 158.85.254.64 0.0.0.31
deny ip any 169.44.23.192 0.0.0.31
deny ip any 169.44.36.0 0.0.0.127
deny ip any 169.44.57.64 0.0.0.31
deny ip any 169.44.58.64 0.0.0.31
deny ip any 169.44.80.0 0.0.0.63
deny ip any 169.44.82.96 0.0.0.31
deny ip any 169.44.82.128 0.0.0.31
deny ip any 169.44.82.192 0.0.0.63
deny ip any 169.44.83.0 0.0.0.63
deny ip any 169.44.83.96 0.0.0.31
deny ip any 169.44.83.128 0.0.0.31
deny ip any 169.44.83.192 0.0.0.63
deny ip any 169.44.84.0 0.0.0.255
deny ip any 169.44.85.64 0.0.0.31
deny ip any 169.44.87.160 0.0.0.31
deny ip any 169.45.71.32 0.0.0.31
deny ip any 169.45.71.96 0.0.0.31
deny ip any 169.45.87.128 0.0.0.63
deny ip any 169.45.169.192 0.0.0.31
deny ip any 169.45.182.96 0.0.0.31
deny ip any 169.45.210.64 0.0.0.31
deny ip any 169.45.214.224 0.0.0.31
deny ip any 169.45.219.224 0.0.0.31
deny ip any 169.45.237.192 0.0.0.31
deny ip any 169.45.238.32 0.0.0.31
deny ip any 169.45.248.96 0.0.0.31
deny ip any 169.45.248.160 0.0.0.31
deny ip any 169.46.52.224 0.0.0.31
deny ip any 169.47.5.192 0.0.0.63
deny ip any 169.47.6.64 0.0.0.31
deny ip any 169.47.33.128 0.0.0.31
deny ip any 169.53.29.128 0.0.0.31
deny ip any 169.53.48.32 0.0.0.31
deny ip any 169.53.71.224 0.0.0.31
deny ip any 169.53.81.64 0.0.0.31
deny ip any 169.53.250.128 0.0.0.63
deny ip any 169.53.252.64 0.0.0.31
deny ip any 169.53.255.64 0.0.0.31
deny ip any 169.54.2.160 0.0.0.31
deny ip any 169.54.44.224 0.0.0.31
deny ip any 169.54.51.32 0.0.0.31
deny ip any 169.54.55.192 0.0.0.31
deny ip any 169.54.193.160 0.0.0.31
deny ip any 169.54.210.0 0.0.0.31
deny ip any 169.54.222.128 0.0.0.31
deny ip any 169.55.67.224 0.0.0.31
deny ip any 169.55.69.128 0.0.0.63
deny ip any 169.55.74.32 0.0.0.31
deny ip any 169.55.75.96 0.0.0.31
deny ip any 169.55.126.64 0.0.0.63
deny ip any 169.55.210.96 0.0.0.31
deny ip any 169.55.235.160 0.0.0.31
deny ip any 173.192.162.32 0.0.0.31
deny ip any 173.192.219.128 0.0.0.31
deny ip any 173.192.222.160 0.0.0.31
deny ip any 173.192.231.32 0.0.0.31
deny ip any 173.192.234.96 0.0.0.31
deny ip any 173.193.198.96 0.0.0.31
deny ip any 173.193.205.0 0.0.0.31
deny ip any 173.193.230.96 0.0.0.31
deny ip any 173.193.230.128 0.0.0.31
deny ip any 173.193.230.192 0.0.0.31
deny ip any 173.193.239.0 0.0.0.31
deny ip any 174.36.208.128 0.0.0.31
deny ip any 174.36.210.32 0.0.0.31
deny ip any 174.36.251.192 0.0.0.31
deny ip any 174.37.199.192 0.0.0.31
deny ip any 174.37.217.64 0.0.0.31
deny ip any 174.37.243.64 0.0.0.31
deny ip any 174.37.251.0 0.0.0.31
deny ip any host 179.60.192.51
deny ip any host 179.60.193.51
deny ip any host 179.60.195.51
deny ip any 184.173.136.64 0.0.0.31
deny ip any 184.173.147.32 0.0.0.31
deny ip any host 184.173.161.64
deny ip any 184.173.161.160 0.0.0.31
deny ip any host 184.173.173.116
deny ip any 184.173.179.32 0.0.0.31
deny ip any host 185.60.216.53
deny ip any host 185.60.218.53
deny ip any 192.155.212.192 0.0.0.31
deny ip any 198.11.193.182 0.0.0.1
deny ip any 198.11.251.32 0.0.0.31
deny ip any 198.23.80.0 0.0.0.31
deny ip any 208.43.115.192 0.0.0.31
deny ip any host 208.43.117.79
deny ip any 208.43.122.128 0.0.0.31

Step #2 – Interface Assignment
Assuming g0/1 is facing your internal network.

router(config)#int gigabitEthernet 0/1
router(config-if)#ip access-group lan-to-internet out

After applying either of these policies, whatsapp should stop working across your network.
However, this does not prevent access over a VPN service.

Leave a Reply

Your e-mail address will not be published. Required fields are marked *